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Presenting Information
Active participation in life’s activities sometimes gives us the opportunity 
to present our information to groups of people. Perhaps we are speaking 
to a parent-teacher group, to a club, or at a business meeting. We may just
want to show our family some photographs. Showing text and graphics 
on a large projection screen or TV is very different from putting the same
information onto paper. You may or may not enjoy speaking to groups, but
having well organized and formatted presentation materials will make your
communications better. 

The layout of information for a presentation is the biggest difference from
paper documents. For example, on paper we often assume our documents
will be in “portrait” orientation.

The term portrait means that the document is taller than it is
wide, like a regular, letter-sized, 8.5 x 11-inch piece of paper. But
computer, projection, and television screens are in “landscape”
format, that is, the screen is wider than it is tall. This will 
force you to think about how the text and images are placed.
Presentations are often formatted with attractive graphic

backgrounds that repeat on every page. A presentation also requires much
larger font sizes, as you have to assume that people will be seated some
distance from the actual screen.
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Presenting information on the Internet requires a different set of formatting rules. The presentation
screen is not as large but it too is in landscape format. On the Web, your presentation has to speak
for itself, so you will make different choices about design elements.

What is StarOffice 8 Impress?
In this guide, you will use the StarOffice 8 Impress presentation application. Presentations are sometimes
called slide shows and Impress has great tools for assembling slides with on-screen communications.
Many of the tools, controls, and commands are similar to those found in StarOffice 8 Draw. However,
there are many new controls for presenting the material. Choices like timing, sound, special effects,
and slide transitions are features that make a presentation interesting. The program will hide all the
tools and menus during the slide show. StarOffice 8 Impress presentations are easily turned into
attractive websites for Internet viewing.

What is a slide show? A slide show is a series of slides, or pages, that present information on a
specific topic. A slide show is a series of pages that are linear, meaning you start at the first slide,
click to the second slide and continue through, one by one. Generally, a presentation is used while
speaking to a group, using your presentation to support and organize your information. Some
presentations, or slide shows, can be used without a speaker, like a collection of photographs. 

You will learn about presentations and how to:
• Create, add, delete, and arrange the order of slides

• Navigate forward and backward through slides

• Create and layout a Slide Show/Slides

• Use the Presentation Toolbar and Wizard

• Create, insert, and use background graphics

• Select transitions between Slides

• Save a presentation as an HTML document for use on the Web

On the Web sun.com/aboutsun/comm_invest
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Let’s Get Started!
Ready to create a slide show presentation? You are going to begin by setting up the background
graphics or theme for the presentation. You will create a title page and a concluding page. Then you
will add your text, images, and data in a logical sequence of slides or pages.

Next, you will make decisions about how the presentation will run. Timing, transitions, and sounds
may be added.

Finally, you will export the whole document to HTML format. HTML stands for Hyper Text Markup
Language. It is a kind of language, or the code for the Web. 

3© 2005 Sun Microsystems, Inc. All rights reserved.



StarOffice 8 Impress On the Web sun.com/aboutsun/comm_invest

4© 2005 Sun Microsystems, Inc. All rights reserved.

Hands-On:

The StarOffice 8 Impress Environment

Impress begins in a different way from the other StarOffice environments. Before allowing you to
work on the actual pages or slides, you must answer some general questions about your
presentation as a whole.

1. Launch the application if you have not already done so.

2. Go to your Programs menu and choose StarOffice 8 > StarOffice Impress.

3. For PC users, go to Start > All Programs > StarOffice 8 > StarOffice Impress.

4. The program will start and unlike the other StarOffice environments you will not be given a 
blank “page.” You will be given the first screen of the Presentation Wizard.

The Presentation Wizard will ask you a series of
questions. You will answer and then click the Next
button. 

5. On this first presentation wizard screen there are three
presentation types to choose from: Empty Presentation,
From Template, or Open an Existing Presentation. For
the purpose of this activity, select Empty Presentation.

If you choose the
From Template

choice on the first screen of
the wizard, you can choose
from pre-formatted
presentations designed for
common business and
personal uses. You can try
this on your own later.

> TIP:

A “wizard” is simply
an assistant. There

are programs and other
computer events that cause
a wizard to appear on your
screen. The wizard presents
a set of questions or options
and you make choices,
which allows the wizard to
prepare the program for
your use.

> TIP:
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6. On the next Presentation Wizard screen you will choose the presentation background or graphic
design of your slide show. Scroll down the list and explore the choices. When you click a choice, it
will display in the Preview area. If you do not see a preview, make sure the preview box is selected.

Choose a background. The background graphics can be changed later if necessary. 
Click the Next button.

7. On the third Presentation Wizard screen there are two slide transition choices, Effect and Speed
(timing). You can ignore these for now as it is easier to make these decisions at a later point.

Click the Create button.
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8. Now that your slide show format is set up, you are ready to start creating your presentation. You
will be presented with your first slide and the StarOffice 8 Impress environment. Examine your
screen and take a moment to look around at the different elements and sections. You have
toolbars at the top, a slide view in the center, and panes at each side.

9. You will notice that the Presentation toolbar is visible.

One of the buttons on the Presentation toolbar is the Add Slide button. Click it twice and add
two blank slides.
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10. You will notice the Slides pane on the left. This functions like the Pages pane in the Draw
environment. It lets you choose the slide on which you wish to work. 

Click the slides in the Slides pane to move around within your presentation.

11. You will notice the Tasks pane on the right. The Tasks pane lets you navigate through the choices
for slide layouts. Choose the slide on which you wish to work. (Look at the image shown in step 8,
the pane on the right side is the Tasks pane.)
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The Tasks pane has four tabs: 

Master Pages, Layouts,

Custom Animation, and Slide Transition.

Click all the tabs in the Tasks pane one by one. As you navigate through each tab in the Tasks
pane, notice what happens to your slide when you apply that screen design or template to your
presentation slide.
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12. You will notice some other tabs just above your slide. Those tabs are: Normal, Outline, Notes,
Handout, Slide Sorter. These tabs will change what you see in the center of your screen. They
change the screen, or the view, so you can work on your slides. 

Do some exploring. Click all the view tabs one by one. Notice how your view of the presentation
changes. Click the Normal tab again.

13. If your Slides pane or Tasks pane disappears you can turn them back on by choosing them from
the View menu. Remember, look a the very top of the program for the menu bar, File, Edit,
View, Insert, etc., not the toolbars below it.

14. Choose Save from the File menu and save your document into your “SO8_YourName” folder.
Name this document “SO8-presentation.”

Inserting Information into the Presentation
Now let’s add text and images to the presentation. Before you start typing or using Copy/Paste and
the Insert menu commands to do so, here are a few things to keep in mind:

• Presentations should not have lengthy text passages unless you have a meaningful quote that you
want to post. You must reduce the information to short passages or bullet points.

• You do not have to tell everything in the presentation slides, as they are intended to support the
speaker who will tell the whole story.

• List six or fewer points per slide. Less is better. It is best to follow the 5 x 5 rule: 5 words per line
and no more than 5 lines of text per slide.

• The size of text on the screen is important. Keep the font sizes at 24 or greater. Your audience
should be able to see the words on the screen from the back of the room.

• Appropriate images can add meaning to your message. Remember, a picture can tell a thousand
words.
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Hands-On:

Choosing the Correct Layout for Your Slides

You have learned to add slides with the Add Slide button and now you will use the Layouts tab of
the Tasks pane to format those slides.

1. Open your “SO8-presentation” document if it isn’t already on the screen.

2. Use the Add Slide button to create enough slides for your information. You can always add more
later. 

3. Click on the first slide in the Slides pane.

4. Explore the different choices for slide layouts in the Layouts tab of the Tasks pane. 

There are several good choices for a title slide depending upon what you want to appear with the
title. As you click the choices, your slide will change to show you the formatting. Choose one.
The example we have created will use the most basic layout, the first one shown on the right.

5. Now click the next slide in the Slides pane. Informational slides can be bulleted, have short
passages, and generally include an image. Make decisions on how your slides will look and
choose the correct layouts. You can always change a layout later. 

6. Repeat step 5 and format all of your information slides.

7. Format your last slide as a conclusion or ending to the presentation.

8. Choose Save from the File menu and save your document.

What is a layout?
A layout is a pre-

formatted slide or template
that allows you to type
directly onto the slide. You
never need to worry about
formatting for clarity or
balance. Layouts have bullets,
some have titles, and others
have made it easy to insert
graphics, graphs, or charts.
The layouts provided in
Impress will make your final
slides look polished and
professional.

> TIP:
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Adding Information to Your Slides
1. Open your “SO8-presentation” document if it isn’t already on the screen.

2. Open your “SO8-writing” document if you wish to use Copy/Paste commands for bringing your
information into the presentation.

3. Open your “SO8-spreadsheet” document if you wish to use Copy/Paste commands for bringing
your table information into the presentation.

4. Use the Window to choose the appropriate document when needed.

5. Choose each slide one by one from the Slides pane and add your information either by typing or
pasting into the pre-formatted text boxes.

6. Choose Save from the File menu often to save your document as you work.

7. You can include additional text boxes on any slide. Use the
Text tool to create the box. Type in your information and
format the text.

8. You can include additional images on any slide. Use the
Picture > From File... command from the Insert menu to
find and place images that you have created or
downloaded.

9. Use the Gallery button to include clip art. 

10. You can include your spreadsheet information on any slide.
Choose Spreadsheet from the Insert menu. Then paste
your information tables into the embedded spreadsheet.

11. Do you have extra slides that were not used? If so, click
to select the extra slide and choose Delete Slide from the
Edit menu.

12. Choose Save from the File menu and save your
document.
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Some of the 
slide layouts have 

built-in functions that help.
For example, the ones with
images allow you to double
click the image location as
a shortcut to using the
Insert Menu, where you
would have two steps
(choosing Picture >
From File...).

> TIP:
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Formatting Your Slide Show
You will set the transition effects and timing settings for your presentation.

1. Open your “SO8-presentation” document if it isn’t already on the screen.

2. Click the Slide Transition tab in the Tasks pane. 

3. Explore the transition choices. Click a choice then click the Play button. You will be shown a
preview of the transition. 

4. Next, choose Slow, Medium, or Fast for the speed of the transition. Preview your choice with the
Play button.

5. Choose a sound to be included with the transition if desired. Note that sounds can interfere with
the information unless they are closely related.

6. Use the Play button to preview your choices again.

7. After deciding on the best transition and settings to use, click the Apply to All Slides button.

8. Decide if you would like to control the timing of the presentation with your mouse and/or arrow
keys or have it play automatically. Choose On mouse click or Automatically after.
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Picking one
transition and

using it on all your slides is
the preferred choice. Having
different transitions is
visually jarring to the
audience and can interfere
with your message.

> TIP:
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9. If you choose Automatically after, set the seconds per slide. This means each slide will remain on
the screen for the amount of time you selected. 

Click the Apply to All Slides button.

10. Click the Slide Show button to preview the entire presentation. You can cancel a presentation by
pressing the Esc key on your keyboard. The presentation will end but the document will still be
on the screen for you to use.

11. You may decide that you would like to rearrange some of
your slides. If so, choose the Slide Sorter tab to display
miniatures of your entire presentation. 

12. In this view you can grab (click, hold, and drag) any 
slide to any position in the show. You will see a black 
bar indicating where the slide will be “dropped” when 
you release the mouse button. Reordering slides is just
that simple! 

13. Choose Save from the File menu and save your document.

In a business
setting, it is more

likely that you will want to
control the presentation
yourself since you will be
speaking from the slides. In
a less formal situation, such
as sharing photos from a
family trip, the automatic
slide show with “looping”
selected is very effective.

> TIP:

The Slide Sorter
view can be helpful

in a number of ways. It is
easy to find blank slides
that should be deleted. You
can also hide slides. You
can apply transitions and
other settings to several
slides at one time from the
Slide Sorter.

> TIP:
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Presenting Your Information

Before giving your presentation to an audience, it is wise to
practice. Practicing with your presentation screens and your
talking points is a good way of preparing for public speaking.

1. Open your “SO8-presentation” document if it isn’t already
on the screen. Be sure you are looking at the first slide.

2. Choose Slide Show from the Slide Show menu or click the
Slide Show button.

3. The slide presentation will fill the entire screen and be
played by either an automatic timing feature or by a
mouse click. At the end, press the ESC key to stop the
presentation.

Printing Your Presentation

There are many printing options for your presentation:
Normal, Notes, Handouts, or Online. These options appear in the tabs area as well as in the Print
screen. The Handouts option gives you the choice of printing one, two, three, four, or six slides per
page. Let’s explore these options.

1. Open your “SO8-presentation” document if it isn’t already on the screen.

2. You can print any of the presentation views: Normal, Notes, Handouts, Outline. After 
choosing Print from the File menu, click the Options button to select the style you 
would like to print. 

3. Click the Printer Options OK button.

4. Click the Print OK button.

Using the arrow
keys (right arrow

to advance and left arrow to
go back) gives you or the
presenter more control than
using the mouse. Other
helpful keys to use are: “B,”
which turns your screen to
a solid black image and
“W,” which will cause your
screen to show an all white
background. These are
useful shortcuts if you need
to pause during your
presentation. Click any key
to return your screen to
your presentation.

> TIP:

POSSIBLE ROADBLOCK: 
Printing a presentation can
use a lot of ink! Whether
you print in color or black
and white, consider
changing a dark background
to something with little or
no background for printing.
You can change your
background back to your
original design for the
actual presentation. You
might create two
versions simply by
using the Save As
option.
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Creating a Web File from your Presentation
If formatted and planned properly, a StarOffice 8 Impress presentation can be viewed on the World
Wide Web. However, you now may want to include some of the details that you removed to make
your presentation. A viewer of a website would expect to read the details, and your presentation on the
Web is probably just one person, so font sizes similar to document size are appropriate. 

Hands-On:
1. Open your “SO8-presentation” document if it isn’t already on the screen.

2. Edit or add content to your slides to make them more complete for posting on the Internet.

3. Choose Save As... from the File menu and save your document with a different name. You will
want to keep your original presentation unchanged. Name this new copy “SO8-
presentation_web”

4. Choose Export from the File menu. 
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For viewing on the
Internet, it is best

to use a simple, plain font
style. Look at your
presentation and decide
which font will be the
easiest to read.

> TIP:
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5. Click the Create New Folder button and name the folder “PresentationWebSite.” You will save the
exported website into this folder because StarOffice 8 will create a number of new documents.
Having a separate folder for your Web page will help organize these new documents, which are
like instructions to the Web page.

6. From the File format box choose “HTML Document.”

7. The main page of a website is often named “index.” Type “index” into the File name box. 

8. Click the Save button. You aren’t finished yet.

9. You will be given the first screen of the HTML Export wizard.

Click the Next button.

10. The next screen has two sets of options. First, the Publication Type. Leave the setting at Standard
HTML format. The next Options allow you to have a title page and to show the notes. De-select
the notes option. Notes are usually just for the author of a presentation. Click the Next button. 

Any StarOffice 8
document can be

converted to a Web site. For
Writer and Calc, use the
Save As... command from
the File menu. Choose
HTML from the File Format
list. For Draw and Impress
documents you will use the
Export command from the
File menu.

> TIP:
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11. The next screen allows you to set the size of the display. The medium setting is a good one. Click
the Next button. 

12. Your next screen choice allows you to enter contact
information. Enter it if you wish. Click the Next button. 

13. Now, the screen choice allows you to pick the graphics to be used in the website navigation bar.
Pick the buttons that best match your presentation’s background. Click the Next button. 
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Most websites
have a “contact.”

You may not want to put
your full name here, you
may want to simply provide
an email address. Whatever
you choose, just think about
what information you are
willing to share publicly.

> TIP:

Navigation:
because a website

needs to provide the viewer
a way to move “forward” or
“backward” navigation is
important. Navigation is
simply the little buttons on
the Web that enable the
viewer to move around a
page or the website.

> TIP:
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14. This screen allows you to set colors for your text. It is probably best to leave this set on “Apply
color scheme from document” unless you know what custom colors you would rather use. The
Next button is not available. Click the Create button. 

15. You will be prompted to save all of your answers in the wizard as an HTML design. Name the
design if you wish and save or skip this option by clicking the Do Not Save button. Saving your
design is like creating a template, it simply means you can use this Web page design another time.

16. Now for the fun part. Your presentation can now be viewed by a Web browser like Firefox. Launch
Firefox and choose Open File... from the File menu.

17. Navigate to your “PresentationWebSite” folder and open the file named “index.html.” What do
you see? Test the buttons and navigation.

Congratulations! You have created a website from your presentation. Placing your website on the
Internet is beyond the scope of this guide but there are some suggested services mentioned in the
Internet guide.

In Your Folder:

Your folder contains a lot of documents now. You may want to delete the ones you don’t want or need. 

Please keep these from the StarOffice 8 Writer Guide:

• “SO8-writing”

• “SO8-writing Final Copy”

Please keep these from the StarOffice 8 Draw Guide:

• “SO8-drawpractice

• “SO-8-logo”

• “SO8-logo-export”

• “SO-8-flyer”
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Please keep these from the StarOffice 8 Calc Guide:

• “SO8-calcpractice”

• “SO8-database”

Please keep these from the StarOffice 8 Summary Project Guide:

• “SO8-brochure” or “SO8-newsletter”

Please keep these from the StarOffice 8 Impress Guide:

• “SO8-presentation”

• “SO8-presentation_Web”

• “PresentationWebSite” folder

You are Using StarOffice 8 for Presentations Now!
You are using powerful tools of presentation. You can also export your documents for viewing on the
Internet. Let’s take a moment to review what you have learned.

• You can create and format slides for your presentations.

• You can add custom graphics and text areas to your slides.

• You can format the actual presentation with transitions, timings, and sounds.

• You can export your presentation to HTML format for viewing on the Internet.

A few more thoughts to keep in mind about using StarOffice 8
Impress to present information
Presentations are a great way to share information with larger groups of people. Remember to use
the presentation document as an outline and guide to what to say, not as a comprehensive list of all
the information. You don’t want your audience to “read” with you. You want them to listen. The
words and bullet points you use should help your audience connect with what you say. Words and
objects should be large, easy to read, and enhanced with graphics. There is a very simple presentation
in the Resources folder. You might want to practice what you’ve learned by using this example.

Congratulations on completing the introduction guides to the most used features of StarOffice 8! You
now have text, graphics, data, and presentation skills that will serve you well. 

At the very beginning of these guides we started off talking about traveling or assisting you, the
“traveler.” You certainly get a sense of travel when you use the Internet. You not only find
information and visit people and places “virtually”, but you can do something, you can participate.
However, you’re not really participating until you write something, create something, and share it.
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Whether you send an email, develop a blog, or think of ways to promote a small business idea, you
need to communicate with words and images. You now have the basic tools to fully participate in a
digital world. You can create a note, letter, outline, flyer, newsletter, or an article. You can build 
a brochure to explain your services, or an idea. You can use a presentation to share with friends or
present to investors or bankers. You have seen how these pieces can be printed or placed on the
Web. The skills you learned in StarOffice 8 are tools that let you surf the Net, post information, and
build websites. You also have the ability to communicate to friends, family members, business
partners, and any other type of audience. The integrated applications in StarOffice can be used for a
wide variety of personal and professional uses.

Like anything else, the more you work with these applications and try things, the better you will
become. Now it’s your turn. Work with what you’ve learned. Some of you will become expert
“Desktop Publishers” and some of you will build sophisticated models with your spreadsheet
capabilities. Whatever it is you do, we’d like to hear from you. We’d like to see your work or hear the
story of what you did and how it changed your communications with others. Send us a note! You can
email the Sun Microsystems Foundation at sunfoundation@sun.com.
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