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Data
Keeping track of important information is a big job for everyone. Some
information is numerical, some is textual and some is graphical. No matter
what form it is in, keeping it organized can be a lot of work. If you have an
active life, you have sets of data that you need to track and keep current.
Perhaps it is a personal address book, a checking account, or a budget. Maybe
you have information about customers for your business, or the financial
records for a group. Some information sets are small and some can be quite
large. Information is dynamic. Some kinds of information changes often, like
friends’ addresses or phone numbers, and some information accumulates,
like expense reporting. Which ever kind of data you are keeping, at some
point you will want help organizing it.

“Data” is the term for all this information. In this guide you will learn how
to use StarOffice 8 Calc, the spreadsheet application that will help you to
organize, find, sort and use your data. Calc will also help us perform math
functions on the numerical parts of our data. 

What is StarOffice 8 Calc?
In this guide, you will use the StarOffice 8 Calc spreadsheet application. A
spreadsheet is really just a very large grid for organizing text or numbers. There
are columns and rows. The individual grid locations can all be independently
formatted in ways that are most appropriate for the information you enter.
Finding information is easy because every “spot” on the grid has an address.

STAROFFICE 8 CALC
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You can keep track of data, sort data in meaningful ways, or do mathematical calculations on your
numbers within a spreadsheet.

You will learn how your information can be organized with headings for each category of data. You
may want to think of this as an organized list where the headings neatly identify each column of the
list. The headings tell what kind of information is in each column. Each row has the information for
each category. You can easily compare, sort or search for the information you need at any one time.
You can organize the information in different ways for different reasons.

Numbers can have any mathematical formula performed on them, they can be added, multiplied, 
or compared in other ways and you can easily adjust them when things change. You can also use
spreadsheets to try different number values, to try “what if” situations. For example, you could try
different expenses in a budget. Your column of numbers will automatically update! 

Spreadsheets are used in many ways. While StarOffice 8 includes a database application, Base,
spreadsheets are frequently used along with databases. Calc includes database functions as it allows
you to use spreadsheets to arrange, store, and filter your data. StarOffice Calc lets you drag-and-drop
tables from databases, or lets you use a spreadsheet as a data source for creating address labels or
form letters. 

In the previous guides, you learned that you can add images to your text, and you learned how to
add text to your graphics. Through this guide, we will focus on the basics of using a spreadsheet. 
You will see how useful spreadsheets can be in working with data. The next guide will show you
some ways to use spreadsheet information in a document. StarOffice 8 helps you integrate all of
these applications to enhance your communications.

You will learn about spreadsheets and how to:
• Navigate and explore the spreadsheet environment

• Work with worksheets

• Create formulas and use the Formula Bar

• Use and format text in a spreadsheet

• Format cells for height, width and color 

• Format numbers for special use, such as money or percents 

• Sort, filter and search data
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Let’s Get Started!
Ready to start organizing some data? In this section you will create two projects using the
spreadsheet program. You will create a spreadsheet document and use at least two “worksheets.” On
one worksheet, you will create lists of information. On the other worksheet, you will add some
numerical information and have Calc do some math for you. In this section you will learn about the
spreadsheet environment, worksheets and formulas.

Formatting is still important so we will talk about that first and you will also learn how to 
“navigate” or move around in your spreadsheet.
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Hands-On:

The StarOffice 8 Calc Environment
1. Launch the application if you have not already done so.

2. Go to your Programs menu, and choose StarOffice 8 > StarOffice Calc.

3. For PC users, go to Start > All Programs > StarOffice 8 > StarOffice Calc.

4. The program will start and you will be given a blank “spreadsheet.” The document will have
three blank “worksheets” or pages. They are named Sheet1, Sheet2, Sheet3.

5. Take a moment and look around the screen. As you’ve seen
with Writer and Draw, there is a familiar look, but there are
some differences from the word processing and graphics
environments. StarOffice 8 will adjust its toolbars and
available functions depending upon what kind of document
you are creating.

• Sheet1 is displayed. You can see the tabs for Sheet2 and
Sheet3 near the bottom.

• Above the grid of the sheet is a new toolbar, the Formula Bar.

• There is a new menu item in the top Menu Bar named Data.

• The other controls and tools should look familiar.

Worksheets are
like pages, or like

“slides” in a Draw document
only much larger. A worksheet
full of information would
take hundreds of pages to
print! Keep that in mind if
you do print, you will learn
how to define a specific area
for printing, and that will be
important! 

> TIP:
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Spreadsheet Navigation and Formatting
Let’s begin by learning how to move around a spreadsheet. Then we will format the parts for clear
communication. Spreadsheets are different from the other kinds of documents that you have been
using. Instead of adding pages as you need them, the size is set already. However, don’t worry, it is
huge! Remember how to use the scroll bars? You will see that a single worksheet provides 65,536 rows
and 256 columns! You will not run out of space for your information. You are given three worksheets
automatically when Calc creates a new document. Since you can only fit about 50 rows of information
on a printed page, there are a lot of pages available. You can add worksheets as well. It can be
awkward to work with a single worksheet that is long, as it requires you to scroll up and down often.
Like all the other StarOffice 8 programs, you decide how to organize and present your information.

Hands-On:

Navigation
1. Let’s begin by learning how to move around in a spreadsheet. First notice which “cell” or grid box

is selected. Its location is A1. The spreadsheet is organized with vertical columns that have letters
and horizontal rows that have numbers. The first cell is A1. The last cell is IV65536.

2. You can tell that A1 is selected because it is outlined and has a special handle in the corner. You
can also see the “address” A1 noted in the Name Box on the tool bar. 

3. If you click in a different cell you will see the outline and the Name Box address change. Do that
now. Click in the box next to A1. Its address is B1. You can click into any cell you want to use.

4. You can use the arrow keys on your keyboard to navigate around the worksheet. Try that now.
Press the right arrow key, the down arrow, the left and up arrow key on your keyboard. Look what
happens to the Name Box and to the cell address. It always shows the selected cell address.

5. You can also type an address into the Name Box. Then press the Enter key. Type A100 then press
the Enter key. Did you move down the page?

6. Now type A1 then press the Enter key. Are you back at the top cell?

7. Now let’s go to Sheet2 and Sheet 3. Look at the bottom of the screen. You will see the worksheet
tabs. Click the tab for Sheet2 to select it, click the Sheet1 tab to go back to that page. 

8. Choose Save from the File menu and save your document into your SO8_YourName folder. Name
this document “SO8-calcpractice.” 



Formatting

In this practice, you will learn how to format words in a spreadsheet, then we'll work with numbers.

1. Open your “SO8-calcpractice” document if it isn’t already on the screen. This document is in the
Resources folder.

2. Click in cell C3 and look at the Formatting toolbar. 

You can see the normal controls for font, size and color, they look the same as controls in Writer
and Draw.

3. Let’s enter some text. Type the word “word” into the cell and then press the Enter key.

4. The data is there but it looks plain. Click back on cell C3.

5. Use the font, size and font color controls to format your text.
It might look like this. 

6. Now let’s explore the new formatting controls for the look
of the cell. Click on cell C3 and use the Background Color
control to color the whole cell. 

7. Now click on the Borders control to place dark outlines
around the cell.

8. Use your cell formatting skills to create a picture like this. 
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You may need to
click away from the

cell you are working on to
see your formatting changes.

> TIP:

You can select
more than one cell

at a time. Try this: with your
mouse, click, hold and drag
across several cells or click
different cells while holding
down the Control key.

> TIP:
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9. It may be easier to format cells by using the Format Cells dialog box. Select a cell or cells. Then
choose Cells from the Format Menu Bar.

10. Now let’s look at formatting numbers. There are tabs for Numbers, Font, Font Effects, Alignment,
Borders, Background and Cell Protection. The Numbers tab lets you format the cell to hold
different kinds of numbers. Type the number 129 in a cell, make sure the cell is selected, then
open the Format Cells dialog and choose the Numbers tab.

11. Click Currency in the Categories box and click the OK button. Look at your number. What
happened to the format? Your number should now be $1.29. The formatting stays with the cell. If
you add a different number it will still be formatted as money.

12. Repeat steps 9 through 11 but try percent, date and text. Note the differences.

13. Next, we will try to align our text inside a cell. Click in a new cell and type a short sentence such
as “The weather report is good..” You will notice that the sentence will not fit in the cell and
seems to spill out into the next cells. 
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Remember to
select the cells

(the destination) before you
apply the format. You will
need to highlight or select
the cells you want to change
before you format the cell(s)
and open the dialog box to
change your information.

> TIP:
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14. Click the cell to select it and choose Cells... from the Format menu. Click the Alignment tab. 

15. You can force the text to “wrap” or stay in the cell by clicking the Wrap text automatically
checkbox. Select that checkbox and then click the OK button.

16. Let’s try that process again. Open the Format Cells dialog again and this time let’s use the Text
Orientation wheel to rotate the text in the cell. Do that and click OK. 

17. You can also change the size of cells by grabbing the dividing line for the column or for the row
and dragging the line to the width or length you want. You can change a cell’s height or length
with this action.

18. Choose Save from the File menu and save your document.

It might be okay 
to have a long

sentence of text spill across
several cells if those other
cells are empty. Allowing
this to happen is one way of
creating a large heading for
a column of information.

> TIP:
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Database Functions
For purposes of this guide, we will show you how to easily perform database functions using a
StarOffice 8 Calc spreadsheet. There are a variety of ways you can do this. You can create a personal
phone directory or a listing of employees by name, gender and pay rates. After you have stored and
organized your data in the spreadhsheet, you can retrieve the information and select portions of the
data to view and use in different ways. In this section, you will learn how to enter and work with
data in your spreadsheet. You can use the example in the Resources folder (Spreadsheet_Example) or
create your own.

Hands-On:

Follow these directions if you want to create your own data.

1. Create a new spreadsheet document by choosing New > Spreadsheet from the File menu.

2. For this exercise our example creates a phonebook of friends and family, limiting the phonebook
to 10 entries. If you want to use your own information decide what information you want to
track. You might decide to keep track of your tools, CDs, books, toys or other possessions, limit
your entries to 10 for now. You can add more information or experiment later.

3. First let’s name our worksheets. Right click on the tab called Sheet1 and choose Rename Sheet...

4. Name it “Phonebook.”

5. Now start to create your headings for the columns. These will be the categories for the
phonebook. At the top of the Columns (A1, B1, etc.), type “First Name” and “Last Name” above
the names and “Phone Numbers” above the phone numbers, or other headings that are
appropriate to your list. 

6. Format the headings so that they stand out from the other information that you will enter. You
can change the font, make the words bold or change the background color. Change the
background color to blue and have the headings fully outlined.

7. Click into cell A2 and start entering your information. You can use the Tab key to easily jump to
the next cell to the right. The Enter key moves your selection to the next cell down. Shift - Tab
moves left and Shift - Enter moves up. 

8. Enter all your data. Don’t worry about formatting. Just as we
learned in the Writer and Draw practice guides it is better to
enter your information first and then go back to work on the
look or formatting of your document.

Remember to 
save your work

frequently! See step #10 
if you want to save your
data now.

> TIP:
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9. Now that your information is complete, select the cells that need formatting. Some columns may
contain numbers that correspond to money or dates. Perhaps you’d like to have each row in a
different color to make the table easier to read. Do that formatting now. 

10. Choose Save from the File menu and save your document into your SO8_YourName folder. Name
this document “SO8-spreadsheet.” 

Skip the next section if you did this work with your own data.

Follow these directions if you want to use the example spreadsheet.
1. Choose Open from the File menu.

2. You must find the Resources folder.

3. Click on the document named “Spreadsheet_Example.” Click
the Open button.

4. Use the information in this worksheet for the rest of this guide.

5. Notice the three worksheet names on the bottom. On the first
sheet (Data Information), practice formatting the headers and
cells. Try some options on your own, like adding color to the
headers or across a row by selecting all the cells a that row. 

6. Practice moving around the table. You can use the Tab key to
easily jump to the next cell to the right. The Enter key moves
your selection to the next cell down. Shift - Tab moves left
and Shift - Enter moves up.

7. Choose Save As... from the File menu and save your document into your SO8_YourName folder.
Change the name this document to “SO8-spreadsheet.” Remember, by renaming this document,
the original document, “Spreadsheet_Example,” will not be changed.
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A “range” of cells
is simply a group

of cells that are selected, or
ones you select. These cells
must be contiguous, or
without any gaps. This 
is very helpful when you 
are selecting parts of a
spreadsheet to copy, or 
to print.

> TIP:
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Sort, Filter and Find: Manipulating Your Data

Manipulating your data means to sort, filter, find and otherwise look at your information in different ways.

1. Open your “SO8-spreadsheet” document if it isn’t already on the screen.

2. Click in cell A2. You can actually click in any cell of your table but not outside the table. This tells
StarOffice 8 to pay attention to the table. The program will “find” your data and the headings.

3. First, you will sort your data. Choose Sort from the Data menu. You will see the Sort dialog box.

4. Choose the most important heading for your information in the Sort by drop down menu. Click the
OK button and look at your data. Now it is arranged either alphabetically or numerically by the
information you chose.

5. Try sorting by another heading.

6. Next you will “filter” your data. The term filtering means
showing only the lines of our spreadsheet that we wish to
see temporarily. Some columns may have the same
information. For example M for male or F for female. You
can temporarily show only the information you need to
see. Click one of the cells. Choose Filter > AutoFilter from
the Data menu.

7. Look at your headings. They now have small controls.

Each row holds all
the information

about one person in our
example table. Being able
to “filter” out the records
you don’t need to see is
very helpful.

> TIP:
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8. Click on one of the Filter controls with the down facing arrow and choose the information you
want “filtered” or shown. 

9. The Filter control will turn blue indicating that it is being used. 

10. Now click the same filter control and choose “All.” The entire set of information will be back in
the spreadsheet.

11. You can turn the Filter controls off by choosing Filter > AutoFilter from the Data menu again.

12. Now let’s find data and change it by using the Find & Replace feature.

13. Choose Find & Replace... from the Edit menu.

14. You will see the Find & Replace dialog box. You will see there are two features, “Search for” and
“Replace with.”

15. Type the text “Gloria” in the Search for box if you are using
the example data or type a word from your information.

16. Click the Find button.

17. If the text exists on your worksheet the cell will be
selected. You may need to move the Find & Replace dialog
box to see what is “beneath” it.

18. Click the Find button again to see if the same information is in another cell.

POSSIBLE ROADBLOCK: 
Be careful and don’t use the
“Replace All” button unless you
really want to replace every
instance of the text in the whole
worksheet. For example, if you
discovered that you had spelled
a name incorrectly you could
replace everywhere at once. If
you chose “Replace,” the
program will show you each
instance of the word
you are looking for and
you can make the
choice to change it or
leave it alone. 
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19. You can easily change the found information by typing in the Replace with box and clicking the
Replace button. 

20. Click the Close button when you are finished finding information.

21. Choose Save from the File menu and save your document.

Data Calculations
Now you are going to have some calculations performed on your data. In this section you will learn
how to work with numerical data; how to apply formulas, and use the symbols that represent
mathematical operations. First you will learn how to enter formulas, then you’ll learn how to apply
these operations and see the results.

Hands-On:

Math Formulas Explained
1. Open your “Spreadsheet_ Example” document from the Resources folder.

2. Click on the 3rd tab which is named “Practice Sheet.”

3. Study the section on Basic Math Formulas. Formulas should be carefully typed. 

4. All formulas begin with an = (equal) symbol. 

5. Then the function name such as “SUM.”

6. Then parenthesis ( ) that enclose the cell addresses with
the data and a connector. Connectors are mathematical
operation signs like +, -, *, /, or continuity markers like 
a colon:

• For example: =SUM(A1+A2) will add the contents of cells
A1 and A2.

• Another example: =SUM(A1-A2) will subtract the contents
of cell A2 from A1.

• Another example: =SUM(A1:A20) will add the contents of all
the cells from A1 to A20.
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POSSIBLE ROADBLOCK: 
Do not press the Enter key if
your cursor is in the middle of a
formula! Get your cursor to the
end of the formula, then press
the Enter key. If you get an error
message in your cell, just delete
your entry and start over.
Another problem occurs when
the program tries to anticipate
which cells you want to use. It
will highlight cells that might
not be correct. Take your time,
watch carefully while you are
creating formulas. Try
not to click in cells while
typing a formula unless
you want that cell
inserted into the
formula. 
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7. To type a formula first decide where you want the result. Click to select that cell.

8. When typing the formulas, you must be careful and press the Enter key to tell StarOffice the
formula is finished after you have entered the entire formula. 

There are two helpful buttons that make creating formulas easier. One is the Sum button. 

9. To use the Sum button, first click to select a cell in an appropriate place. Remember, Sum is the
“answer” or the result from adding numbers, so an appropriate place will be below a list of numbers.

10. Then click the Sum button. StarOffice 8 Calc will “look around” your selected cell to see what
should be added up. If there are a group of numbers nearby, it will use those. These images are
screen shots that show the Practice Sheet right after
clicking the Sum button and right after pressing the 
Enter key to accept the formula.

The other useful button is the Function Wizard button. This is the smart way to create more
complicated formulas. It allows you to choose the operation (the mathematical action you want)
and the cell addresses in much more detail. The Function Wizard takes some study and practice
to use. If you want to use this or learn more, search for “Function Wizard” in StarOffice help. 

You can easily
have your

spreadsheet learn to count.
Type the first two numbers
of a counting sequence next
to each other. Select those
two cells. Then carefully
drag the handle down a
number of cells. Calc will
fill in the cells with the
correct numbers.

> TIP:
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11. Use your new formula skills to fill in the practice table.

12. Choose Save from the File menu and save your document.

Hands-On:

Setting Up Calculations
1. Open your “SO8-spreadsheet” document if it isn’t already on the screen.

2. Click on the second worksheet tab. Right click on the tab and choose Rename Sheet... Name it
“Calculations Sheet.”

3. Create a set of information similar to the one you created on the data information sheet. You 
can use Copy/Paste to bring sections of information from your data. Be sure to include some
numerical information in a least one column. The Spreadsheet_Example uses “Hours worked” 
and “Rate of Payment” for the numerical data. 

4. Create a column of cells for the results of the calculations.
Column D, Payment Owed is our example that shows the
calculations.

5. Use your formula writing skills to perform the appropriate
calculations on your data. Our example shows the Hours worked
multiplied by the Rate.
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You can easily
have your

spreadsheet “fill” a column
or row with information.
Type the data into a cell.
Select that cell and a range
of cells with it. Choose Fill
from the Edit menu. 

> TIP:
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6. Now experiment with your data. One of the best features of spreadsheets is that they can answer
“what if” questions. You can change your data see what happens in the formula results. In the
Spreadsheet_Example, if we changed Masse’s hourly rate to $30.00 we will see quite a change in
our total. 

7. Do this with your data and see what happens. Change some of your data cells and note the
differences in the result cell.

8. Choose Save from the File menu and save your document.

In Your Folder:
Your folder contains a lot of documents now. You may want to delete the ones you don’t want or
need. 

Please keep these from the StarOffice 8 Writer Guide:

• “SO8-writing” 

• “SO8-writing Final Copy”

Please keep these from the StarOffice 8 Draw Guide:

• “SO8-drawpractice”

• “SO-8-logo”

• “SO8-logo-export”

• “SO-8-flyer”

Please keep these from the StarOffice 8 Calc Guide:

• “SO8-calcpractice”

• “SO8-spreadsheet”
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You Are Using StarOffice 8 for Data and Calculations Now!
You are using powerful tools of organization and calculation for your information. Let’s take a
moment to review what you have learned.

• You can format individual or a range of cells in a spreadsheet.

• You can create and navigate worksheets within spreadsheets.

• You can organize informational data with StarOffice 8 Calc.

• You can perform calculations on data.

• You can write and use spreadsheet formulas to analyze your information.

A few more thoughts to keep in mind about spreadsheets...
Spreadsheets are great tools to use when you want to see information in a grid. Keep StarOffice 8
Calc in mind for shopping lists, planning sheets and more. Worksheets are easily added to an existing
Calc document to create a whole book of information. Use the Sheet... command from the Insert
menu to add them. You can name your worksheets to make them more descriptive. Right click on the
tab and choose Rename Sheet.

StarOffice Calc is a spreadsheet application that you have used to calculate, analyze and manage
your data. Because Calc, like all the StarOffice 8 applications, includes the ability to save your work 
in other formats, you can also import and modify Microsoft Excel spreadsheets. There are a lot of
advanced features built into spreadsheets. For example, numbers can easily be converted into a chart
or graph, which is a great way of showing numerical data visually. Also, spreadsheet information can
be used to help create databases, or to add detail or lists of information to word documents.

In addition to the Help menu in the application, there are excellent books and online resources
available for study if you are interested in becoming more of an expert. Many people use spreadsheets
for very simple things. What are some ways that you could use spreadsheets to organize information
in your life, home and at work? Remember, a spreadsheet is easy to correct and to update items,
unlike a word processing document where changes can upset the formatting of the pages, the “grid”
of a spreadsheet format keeps the information organized.
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