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Graphics
They say a picture is worth a thousand words. Pictures are often used along
with our words for good reason. They help communicate our thoughts. They
give extra information that is hard to put into words. They add “color” to
the content. Sometimes feelings can be shown with a picture. They can help
organize the page as well. Images make documents more interesting, more
fun, more polished and professional. We can use words like pictures when
we change the font, size and color.

“Graphics” is the term used for computer pictures, images and photos. 
We have all made drawings, maps, doodles, plans and photographs for
ourselves but have you ever used the computer to create them? In this
guide you will learn to create and use graphics on the computer. You don’t
have to have artistic talent to create computer graphics. Keep in mind that
the term “graphics” also refers to how you arrange the text and images on a
page. We can all make decisions about that. You already know how to add
and adjust clip art and images you have saved to a StarOffice 8 Writer
document. In this guide you will learn a lot more! Learning to use computer
graphics will make your documents more interesting. They will
communicate your thoughts, feelings and ideas in a more meaningful and
memorable way.

STAROFFICE 8 DRAW

On the Web sun.com/aboutsun/comm_invest



StarOffice 8 Draw On the Web sun.com/aboutsun/comm_invest

2© 2005 Sun Microsystems, Inc. All rights reserved.

What is StarOffice 8 Draw?
In this guide, you will use the StarOffice 8 Draw program and two main features, creating graphics
and page layout. Graphics, of course refers to creating actual pictures and designs that have line,
shape and form. The term “layout” means that you will be in full control of your document’s parts,
you can arrange text and images just the way you want. StarOffice 8 Draw lets you do both.

The tools and functions in Draw allow you to create new graphics or edit existing ones. There are
tools for Shapes, Lines and for Color control. There are controls for turning text into “art.” Lines and
designs can be arranged, lined up, stacked, grouped and duplicated. 

The page layout tools and functions allow you take any part of a document and place it exactly
where you want it on any page. You become the graphics designer and create pages for publication.
This is called “Desktop Publishing.”

You will learn general tips for creating graphic elements and how to:
• Create, move, rotate, size and delete graphics

• Align, group and arrange objects

• Save graphics in an alternate GIF format

• Apply colors using the Color Bar

• Layer graphic images

• Layout a document with graphics

• Create and format lines 

• Use the Pages Pane, Shape Tool and Color Bar

• Add Text Elements
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Let’s Get Started!
Ready to start creating graphics? You are going to begin by creating some artwork with the shape
and line tools. You will save your work in two different formats; a StarOffice 8 Draw document and a
GIF, or Graphical Interchange Format. Like any document, it can be edited or changed later. Saving an
image to an alternate format like a GIF is done by “exporting” your image or document when the
graphic is finished.

After you create a graphic, you will work on the layout of your page. You will learn how to layout a
page using the graphics and text elements that you create in this guide as well as using some of the
text you created in the previous Writer guide. 
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Hands-On:

The StarOffice 8 Draw Environment
1. Launch the application if you have not already done so.

2. Go to your Programs menu and choose StarOffice 8 > StarOffice Draw.

3. For PC users, go to Start > All Programs > StarOffice 8 > StarOffice Draw.

4. The program will start and you will be given a blank “page.” 

5. Take a moment and look around the screen. It is similar to the screen you saw in Writer, but has
some differences. In addition to the toolbars on the top and the color and drawing elements on
the bottom, there are two large sections. StarOffice 8 will adjust its toolbars and available
functions depending upon what kind of document you are creating.

• Your slide (or page) is displayed on the right. It has been scaled so you can see the entire page
on your screen.

• On the left you will see the “Pages” pane. An area for keeping track of your slides.

• There are new toolbars showing. The Line and Filling toolbar is above your slide and the
Drawing toolbar is below along with the Color Bar.
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Graphics with StarOffice 8
Now we are going to learn ways to create shapes, lines, text boxes and more.

Hands-On:

Creating Shape Graphics
1. Let’s begin by creating some shapes. Choose the Rectangle tool from the Drawing toolbar.

2. Move your mouse to the middle of the blank page. Then click, hold and drag down and to the
side in a diagonal direction. You will see a white rectangle. Let go of the mouse button and
you’ll see a blue rectangle with a thin black outline.

3. Try it again. Select the Rectangle tool then click, hold and drag. You must hold the mouse
button down while you drag, that tells the program how far to keep drawing the rectangle.

4. Now let’s play with the shapes you’ve created. You may have noticed the small green-colored
squares on the corners of your shapes. These are called “handles.” The handles tell you that the
shape is selected and that you can change its size.

5. If you don’t see any handles, click directly on one of your shapes.

6. Now click different colors in the Color Bar. What happens? 

The Color Bar is a quick way to change the main color choice for an object, but there is a better way.

7. Look at the Line and Filling toolbar. 

8. It has 2 main areas; one for the inside or filling and one for the outside or line. 

9. Select your rectangle by clicking on it once if it isn’t selected already and experiment with the
Filling controls. From the Area Style / Filling control you can make various changes to the
inside of your shape.
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10. Another feature, Area Formatting, on the toolbar, will also change your graphic. Using the tabs
from this dialog box, you can make all the choices about your shape, including options for
transparency and shadows.

11. Now let’s work with the outline part of your shape. Select your rectangle by clicking it once if it
isn’t selected already and experiment with the Line controls. Look at the Line and Filling toolbar.

• The Line Style control lets you pick from a list of different line designs.

• The Line Width control lets you change the thickness of the outline.

• The Line Color control lets you pick from a list of different colors.

12. Try clicking the Line Formatting control on the toolbar. You can make all the choices about your
outline on the different tabs including line style. 

The transparency
control allows the

viewer to “look through”
the object or color. You can
see what is under the
selected image. It is
controlled with a
percentage; 100% is totally
clear like glass, 50% would
resemble dark glass, 0% is
solid color with no
transparency.

> TIP:
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13. Now, experiment with these other shape tools; 

• Ellipse 

• Basic Shapes 

• Symbol Shapes 

• Flowcharts 

• Stars

Remember: If there is a small triangle on the tool button you can click and hold to select different
ways of drawing that object.

14. See if you can make a shape that looks like this.

Add pizzazz to your documents with interesting shapes
from the shape tool. All you have to do is click, hold and
drag the handles to make the shape the right size for your document.

15. Choose Save from the File menu and save your document into your SO8_YourName folder. Name
this document “SO8-drawpractice.” 

To create this star
use the 6-Point

Star variation from the Stars
tool to create the shape.
Then choose “Gradient” and
the green and yellow choice
from the Area Style/Filling
control. Finally, click the
Shadow button to add the
drop shadow.

> TIP:
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Creating Line Graphics
1. Open your SO8-drawpractice document if it isn’t already on the screen.

2. Create a new slide to work on. Select Slide from the Insert menu. You can change pages by
clicking on the small thumbnail pictures of your pages in the Pages pane. 

3. Now let’s create some lines. Choose the Line tool from the Drawing toolbar.

4. Move your mouse to the middle of the blank page. Then click, hold and drag down and to the side
in a diagonal direction. Let go of the mouse button and you’ll see a black line with a selection
handle on each end. 

5. Try it again. Select the Line tool then click, hold and drag. You must hold the mouse button
down while you drag, that tells the program how far to keep drawing the line.

6. Now let’s play with the lines you’ve created. 

7. If you don’t see any handles, click directly on one of your lines.

The word “slide”
and “page” are

almost used the same in
Draw. Slide is what is used in
the menu bar. Slide creates a
new page for you to work
on. Page is what is used in
the left side navigation
area, which lets you move
from one slide to another.

> TIP:
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8. Look at the Line area of the Line and Filling toolbar. 

• The Line Style control lets you pick from a list of different line designs.

• The Line Width control lets you change the thickness of the outline.

• The Line Color control lets you pick from a list of different colors.

9. Try clicking the Line Formatting control. You can make all the choices about your outline on the
different tabs including transparency and shadows. 

10. Now experiment with these other line tools: 

• Line ends with Arrow

• Curve

• Lines and Arrows

Remember: If there is a small triangle on the tool
button you click to select different ways of drawing
that object. The Arrow Style button, on the
Formatting toolbar, is an example of this.

11. See if you can make a line that looks like this. 

12. Choose Save from the File menu and save your
document.

To create this line
use the Line tool

to draw it. Then choose Red
from the Line Color control.
Then choose a Line Style 9
from the Line Style control.
Then choose .10” from the
Line Width control. Finally,
add an arrow from the
Arrow Style control.

> TIP:
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Creating Text Boxes
1. Open your SO8-drawpractice document if it isn’t already on the screen.

2. Create a new slide to work on. Select Slide from the 
Insert menu.

3. Now let’s create some text boxes.

4. Choose the Text tool from the Drawing toolbar.

5. Move your mouse to the middle of the blank page. 
Then click.

6. You will see a text box that is in “typing” mode.

7. Type a few words, the box will grow large enough to hold the text.

8. Click away from the text box, then click it again. You will see the text box in “object” mode with
the green handles showing. 

• You can change the colors and outline just like you did with the rectangles and other shapes.

• To change the text or add to it, double click the text box. Your cursor will appear inside the
text box, near the text.

• Font, size and font color can be changed by selecting the text and making the changes. The
text Formatting toolbar will appear. Your text might look something like this.

• You can also Paste text into a text box. Remember all that text that we already wrote from the
StarOffice 8 Writer guide? It could be reused here.

9. Choose Save from the File menu and save your document.

When you are
designing a

document that has both
graphics and text together,
oftentimes text boxes are
used as containers for
pictures and labels. A text
box is treated like a graphic.
The text box may also be
called an “object.”

> TIP:
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Graphics and Objects
“Objects” are images, graphics, text boxes or other things that have been created in Draw that can
be used, arranged and/or aligned in special ways. Since each “thing” you have created is its own
object, each one can be independently moved, arranged, copied, deleted and placed. Now we can
begin to think about how our pieces might work together, or the “layout.” Let’s get started.

Hands-On:

Moving, Sizing, Copying and Deleting Graphic Objects
1. Open your SO8-drawpractice document if it isn’t already on the screen.

2. Click on slide 1. It probably has several shapes. 

3. Click on a shape to select it. The green handles will appear.

4. Grab one of those handles with your mouse (click, hold, drag) to change the size.

5. Make the shape fat. Make it skinny.

6. Remember, you can grab the picture anywhere inside the handles to move it around on the
page. Move the shape to the top of the page. Move it to the bottom.

7. You can press the Backspace or Delete key to remove the object.

8. You can use the Cut, Copy, Paste commands with objects just as you can with text.

9. Try it now. Click on an object. Choose Copy from the Edit menu. Choose Paste from the Edit
menu. At first you won’t see the new shape. Click, hold and drag and you will see that it was
pasted right on top of the original object.

10. Choose Save from the File menu and save your
document.

Remember! When
you Copy a shape

and then Paste it, you may
not see the new image.

Why? It’s probably right on
top of the original one. Look
for your copied object by
placing your cursor or
pointer on a green handle
and “drag” the object. Do
you see 2 images now?

> TIP:
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Arranging and Grouping Graphic Objects
1. Open your SO8-drawpractice document if it isn’t already on the screen.

2. Create a new slide to work on. Select Slide from the Insert menu.

3. Create three squares and change the colors so that one is blue, one red, one yellow. 

4. Now we are going to select all three squares at once. While
holding the Shift key down. Click each square. 

5. Choose Alignment > Left from the Modify menu. Do you see all three squares lined up on the left?

6. Click the Undo button. Did the three squares return to their original locations on the page?

7. Now, let’s try another way of aligning our squares. Choose Alignment > Top from the Modify menu. 

What happened this time? Are they lined up by the top edges? Now you have powerful tools of
alignment for all your objects. Try the other alignment choices. Remember, you can always click
“away” or “off” to deselect an object. Then move them around one at a time to start over.

Grouping is a time
saving technique

that allows the designer to
change more than one
graphic or object at a time.
If several squares need to
be red, then a group can be
created, and you can select
the new (grouped) object to
make your change, rather
than making each square
red, one a time.

> TIP:
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8. Now we are going to “group” the squares. Grouping simply means to collect two or more objects
so that they can be changed or edited a though they were one single object. This can be very
handy! Select all three squares again using the Shift key method you just learned.

9. Choose Group from the Modify menu.

10. Now the three squares will behave as a single graphic object.
When you click anywhere on any of the three squares the
whole “group” will be selected. 

11. The group can also be “un-grouped.” Choose Ungroup from the Modify menu. Try it.

12. Choose Save from the File menu and save your document.

Layering Graphic Objects

Each object that we create in Draw exists on its own layer. When we create a new object its layer is
“above” the previous one. Objects on lower layers can become hidden by the objects on higher
layers. But you are in control. You can change any object’s layer at any time.

1. Open your SO8-drawpractice document if it isn’t already on the screen.

2. Choose the slide with the three squares. One red, one blue, one yellow.

If you have been saving your document, this will be your 4th slide. Look for slide #4.

Remember, you
can “Ungroup”

objects if you need to change
one of the elements. For
example, you may want to
edit text in a text box and
then group the box with
other objects again.

> TIP:
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3. Drag them until they are partially on top of each other. 

4. Click the corner of the one on the bottom. We’re going to move it up, or “forward” in the stack.

5. From the Modify menu, choose Arrange > Bring Forward.

What happened? The square from the bottom is now in the middle.

6. Repeat step 5, the selected square is now on top of the stack. 

7. Now experiment with the other commands in the Modify menu under Arrange. Remember to
select the object or objects that you want to modify.

8. Choose Save from the File menu and save your document.

Adding Text and Rotating Graphic Objects

1. Open your SO8-drawpractice document if it isn’t already on the screen.

2. Create a new slide to work on. Select Slide from the Insert menu.

3. Use the Rectangle tool to add a shape to your page.

4. Now instead of clicking to select, double click. The object
will still be selected but you will also see a blinking text
cursor in the object. 

Adding text boxes
and rotating

graphic objects can be a lot
of fun! You might want to
have a label sideways or
vertical, upside down, or
backwards. Try some of
these ideas on your own.

> TIP:
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5. Type some words. This text becomes part of the object it is not a separate object. 

6. You can select, change and format this text whenever you
wish by double-clicking.

7. Now let’s turn this object on an angle. Sometimes we need
objects and text to run vertically.

8. Click away from your rectangle with the text and then click it
again to select.

9. Choose Rotate from the Modify menu. The handles will look
different now. They are red circles. 

10. Move your mouse to one of the corner handles and you’ll see the arrow change to a circle with arrows. 

11. Click, hold and drag and you will be able to “spin” the object vertically.

12. Choose Save from the File menu and save your document.

Adding text to an
object directly is

the preferred way of putting
text within a shape if you
want the text to be right in
the middle of the object. If
not, add a separate text box
and group it with the shape.
If you need help to align or
group objects, refer to
earlier steps in this guide.

> TIP:
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Saving Your Graphics a Different Way
1. Create a new StarOffice 8 Draw document. Choose New > Drawing from the File menu.

2. Create an arrangement of shapes, lines and text. Perhaps a logo for yourself or your business.
Start with a diamond shape from the Basic Shapes tool.

3. Give the diamond an interesting fill choice.

4. Add a rectangle with a contrasting color or fill.

5. Add an oval with a contrasting color or fill.

6. Add a text box. Type your name and format the text.

7. Use the skills you learned above for grouping all the 
objects in the arrangement into one object. Keep the
resulting group selected.

8. Choose Save from the File menu and save your document. 
Name it “SO8-logo.”

Creating Your Graphic for the Web

Now that you have created an image in a Draw document, wouldn't it be great to use that image in
other ways? 

1. Your document was saved as a StarOffice 8 Draw document but let’s assume you want to share
this graphic by placing it on an Internet web page, using it in another program, or sending it as
an attachment in an email message. To do that we should save it in a different way. We have to
export it to a different format. GIF is a common format for web graphics.

2. Open your SO8-logo document if it isn’t already on the screen.

3. Select your logo. You should see the green handles when it is selected.

4. Choose Export from the File menu.

5. Choose GIF - Graphics Interchange Format (.gif)

6. Name it “SO8-logo-export.”

Your exported graphic can now be used in almost any program and
on the Internet.

POSSIBLE ROADBLOCK: 
In creating a gif, or saving
your object for some other
format, please note: if you
do not group your
objects and keep
them selected
they will not
export correctly.

It can be difficult
to tell if you have

selected all the elements,
or graphic pieces, you want
to group. One way to check
your “group,” is to copy the
object you have “grouped,”
paste it on your page and
simply look to see if all the
elements are there!

> TIP:

Common formats
for web use are

JPG and PNG. These format
options are available when
you are exporting your
graphic. 

> TIP:
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Page Layout
With your new skills, you can create a flyer, poster, or an invitation. Now that you understand how to
use the StarOffice 8 Draw tools and commands to create graphics let’s use those graphics and create
an entire page that is organized to clearly communicate something specific. You will lay out the parts
of your document and arrange them. You will use many of the tools and skills you just learned to
create a flyer for yourself or your business.

We will be using the graphics you just created in this guide and some text. 

Let’s get started. Our example will be a party invitation, and we will include driving directions as a
graphic to help communicate to our guests. What other kinds of information will be needed? Before
you get started, think about your audience (who the invitation is for) and the detailed information
that is necessary for good communication.

Hands-On:

Let’s Set Up the Page then Add the Graphics and Text
1. Create a new StarOffice 8 Draw document. Choose New > Drawing from the File menu.

2. Think about how you want your flyer to look. You will be able to change it as you go of course but it
can be helpful to have a plan. The example in this guide includes a vertical title, an area for
information and an area for a map.

3. The map will take the most time. Let’s use our graphics skills to
create it first. Remember to use Group from the Modify menu to put all the parts of your map
into one object. 

REMINDER: 
Watch out for the margin
lines. Your page has a thin
light gray outline that shows
the exact area that will be
printed. Don’t put any of
your objects outside that
margin line.

The example 
map in step 3

used: 4 lines, 3 text boxes, 
1 embedded text note 
and a clip art picture from
the gallery. 

> TIP:
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4. Next, let’s create the vertical title. As you can see, the title spans the length of the page. Create a
rectangle with the Text Box tool, and add the text, “It’s a Party.” Now, rotate the text box
vertically, and place it in the correct spot.

5. Next, let’s create the text boxes for the information area. 
You might want a heading box and another text box for the
general information. You can use Copy and Paste to bring in 
text from another document if you wish or just type 
in new information.

6. Now use your skills of arrangement to make your flyer like
look just right. You can line up sections or add drop shadows; experiment with areas and lines
until it is perfect. If you would like to see this flyer, a copy is in the Resources folder.

7. Choose Save from the File menu and save your document. Name it “SO8-flyer.”

8. Let’s do one last Save to your flyer. Once you have a document like this completed, there is a
great way to save it so anyone can open it. If you closed your document, open it once more. With
“SO8-flyer” open and on the screen, look at the Standard toolbar. Do you see the little PDF icon?
It is the sixth icon from the left. Select this button. You will get a Save dialog window and can
name your document. Try it! We will use this PDF option in a later guide.

The vertical title
on a flyer is great

place to use the Fontwork
Gallery. Choose a Fontwork
design then double click the
object to add your own text.
It can then be rotated and
formatted just like any
other object. The Fontwork
Gallery is on the Drawing
tool bar.

> TIP:

POSSIBLE ROADBLOCK: 
When you paste text into a
text box that you copied
from another document the
box may stretch into a very
wide shape. Grab
one of the corner
handles and re-size
your text box.
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Do you like the flyer? Want to change it around? Ours is pretty
basic but it’s a good beginning! Change the font, the title, the
background! Have fun with your flyer. This is the creative part.
You can look for interesting graphics or more interesting ways to
layout your invitation!

You may want your flyer to be wider than it is tall. This is called
Landscape format. To change between Portrait and Landscape
format, choose Page from the Format menu. Choose the Page
tab and click the Landscape checkbox. 

In Your Folder:

Your folder contains a lot of documents now. You may want to delete the ones you don’t want or need.

Please keep these from the StarOffice 8 Writer Guide:

• “SO8-writing” 

• “SO8-writing Final Copy” 

Please keep these documents from the StarOffice 8 Draw Guide:

• “SO8-drawpractice” 

• “SO-8-logo” 

• “SO8-logo-export” 

• “SO-8-flyer” 

To copy text from
another document

first open that document.
Then select the text you
want to use. Choose Copy
from the the Edit menu.
Use the window menu to
bring the document you
need to the front. Click in
the text box where you
want the copied text to be
placed. Choose Paste from
the Edit Menu.

> TIP:

POSSIBLE ROADBLOCK: 
This is the “icing on the
cake,” the fun part. But
remember that too many
features take away from the
meaning and the message.
Pay attention to the white
space as much as
the graphic
elements to
evaluate your
invitation.
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You are a Desktop Publisher Now!
You are now using text and graphics tools and commands to communicate with StarOffice 8. 
Let’s take a moment to review what you learned.

• You can now create and format shapes, lines and text boxes.

• You can now arrange, align, group, delete, copy and rotate graphic objects.

• You can export your graphics for the web and other applications.

• You can use the functions of StarOffice 8 Draw and your desktop publishing skills to layout 
pages for printing.

A few more thoughts to keep in mind about 
using StarOffice 8 Draw to publish documents...
There are four basic principles that graphic designers use when
creating documents. When they create a document, they
include graphics or graphic design elements. Designers know
that interesting documents are not only easier to read, but the
information is more effectively communicated. Think about
these principles as you create your documents.

• Proximity: Keep things that go together close together.

• Alignment: Keep things lined up.

• Repetition: Use the same colors, pictures, fonts, etc. over
again.

• Contrast: If you make something different, make it really
different.

Remember, concentrate on your message first. The four W’s
(who, what, where, when and sometimes why) are very
important. Content should be accurate, informative and 
easy to read.

One more
reminder

about StarOffice documents.
In this guide you saved your
document in different file
formats, a gif and as a PDF.
This is a very important
feature of StarOffice. When
you want to share files or
documents you have created
with StarOffice, you may
want to save your file in a
different file format. An
example might be saving a
file as simple text to allow
someone who does not have
StarOffice to open your
document.

> NOTE:


